Archive

Posts Tagged ‘2007’

All sites search scope returns results, This Site scope returns no results


I had an interesting issue at the customer. When searching through the search center (all sites scope) it returned results from site X. However, when I did the same query in the This Site:X scope, I had no results returned. The full crawl and the incremental crawl did work fine (as in that case All Sites wouldn’t return results anyway). As it turns out this is also related to the loopbackcheck issue in IIS/SharePoint. If you see this behavior on your SharePoint environment you should see acces denied errors popping up in your event viewer and you can refer to this post to fix it: https://koenvosters.wordpress.com/2009/06/15/access-denied-when-using-hostname-search-and-site-on-moss-2007/

Advertisements

SQL Aliasing within SharePoint

March 29, 2010 1 comment

As I recently heard about SQL Aliasing I tried to figure out how it all works. There is a nice post by Thomas Vochten on the subject on how to set it up :
http://thomasvochten.be/blog/post/2009/03/19/Using-SQL-Aliases-with-SharePoint.aspx

Things to take into account :
SQL Aliasing is NOT configured on the SQL Server, it is configured on every server of your SharePoint Farm.
If you want to add servers to an already existing farm and you can’t find any documentation on the aliases, just go to one of the servers in the farm and run cliconfg.exe.
The advantage of this approach is that if you ever want to move your SharePoint databases to a new SQL Server all you need to do is change the SQL Alias.

Categories: 2007, SharePoint Tags: , , ,

The Web application at (url) could not be found.

February 1, 2010 1 comment

Possible causes:

– You made a typo.
– You made a typo.
– You created a SharePoint 2007 x64 development machine. Don’t do that, make a x86 (32bit) installation and forget about developing under x64 for MOSS 2007.
– You are running a website that accesses SharePoint data and the application pool does not have the same identity as the application pool SharePoint is running under. In my opinion this should work with any identity as long as it has acces to SharePoint but clearly it doesn’t… Rules there are supposed to be that the user accessing the SPSite object should be a site collection administrator?

Note that I added you made a typo twice, it’s because for some reason in my environment the create a new web application page added a dot (.) after my servername, so my web application url was http://servername.:2010 instead of http://servername:2010. Internet Explorer works PERFECTLY when you use http://servername:2010 without the dot (.) but when you copy this into your code it gives an error as it is looking for http://servername.:2010. This one got me stuck for quite a while.

I found my theme back!

December 16, 2009 2 comments

Yep, after spending some time in the theme selector I found my theme back. I changed it to a nice red for the christmas period.
Today is gonna be a good day :p On a sidenote, I’m looking into MVC and learning some cool stuff, soon back to SharePoint 2010 though 🙂

Categories: Personal Tags: ,

ERROR: Failed invoking job id

December 14, 2009 1 comment

This blog post (and eventual updates) can now be found at my new blog : http://www.koenvosters.be 
Url of this blog post: http://www.koenvosters.be/post/error-failed-invoking-job-id.aspx

Today my development machine decided to crash and burn down. SharePoint Central admin was no longer working. When that no longer works, step one is to start the configuration wizard and hope it fixes everything. But that failed as well. It did however gave me an exception that helped me figure out what was going wrong: An exception of type System.Security.Principal.IdentityNotMappedException was thrown. Additional exception information: Some or all identity references could not be translated.
In my SharePoint logs I had the following error popping up constantly:

12/14/2009 13:50:01.32 OWSTIMER.EXE (0x0160) 0x0168 Windows SharePoint Services Timer 5uuq Unexpected ERROR: Failed invoking job id {A71C27B4-9023-4727-A90B-3E60171CF790}
12/14/2009 13:50:04.31 OWSTIMER.EXE (0x0160) 0x00DC Windows SharePoint Services General 8e2s Medium Unknown SPRequest error occurred. More information: 0x80070005

So something was wrong with the identities. As it is a development box and no one else touches it but me I knew none of the identies/passwords were changed. I have no clue how it went wrong, but by making use of stsadm -o updatefarmcredentials -userlong -password I managed to get everything up and running again.

BIWUG – SharePoint 2010 – 17 december 2009

December 10, 2009 Leave a comment

The BIWUG Team (Belgian Information Worker User Group) is organising some new sessions on SharePoint 2010. The first session is taking place on 17 december 2009 at the buildings of Ordina in Mechelen.
Agenda:

18:00 – 18:30: Welcome

18:30 – 19:00: Introduction to SharePoint Server 2010 (Karine Bosch – SharePoint MVP)
19:00 – 19:30: LINQ to SharePoint (Stephane Eyskens – SharePoint MVP)
19:30 – 20:00: Client Object Model (Jan Tielens – SharePoint MVP)

20:00 – 20:15: Break

20:15 – 20:45: Business Connectivity Services (Frank Cleynen)
20:45 – 21:15: Workflow (Peter Plessers)

See you there!

Categories: Uncategorized Tags: , ,

Using Javascript and jQuery in MOSS

October 15, 2009 Leave a comment

Jan Tielens released a very nice solution to allow you to easily integrate Javascript and jQuery in your SharePoint sites without having to go through several configurations steps. It allows you to just upload your javascript files to a document library and they will be available in your SharePoint pages. Check it out here.